Boost logo

Boost :

From: David Abrahams (abrahams_at_[hidden])
Date: 2000-07-28 12:27:49

None of the names I've seen floating around recently address the important
difference between what we're trying to name and the standard assert(),
namely that ours happens at compile-time. If you're concerned about what
unfamiliar readers will be able to understand, consider this possible
"What's this 'verify()' thing? Oh, wonderful. Another case of 'plain old
assert isn't good enough for me, I'll write my own'. Stupid boost."

COMPILE_TIME_ASSERT says what it means.
----- Original Message -----
From: "Beman Dawes" <beman_at_[hidden]>
To: <boost_at_[hidden]>; <boost_at_[hidden]>
Sent: Friday, July 28, 2000 11:05 AM
Subject: Re: [boost] metactrl header [compile time asserts]

> Nathan Myers wrote:
> >To choose a name, we should consider how it will be perceived by
> >people trying to read unfamiliar code. Maybe they just encountered
> >"boost::" and haven't memorized everything in it yet. How can we
> >help them?
> Good point. Exactly.
> >
> >Something that implies a "fait accompli" would be better, implying a
> >static condition rather than an action to perform. Then, we can
> >consider "checked" "proven", "verified", "known", "required". However,
> >grammatical correctness is why "assert" works so well, and none of
> >these last satisfy it.
> Action sounds better to me. How about "verify"?
> >A side issue... it appears to me that the proposed expression would
> >not be appropriate for use in header files. Am I right?
> Sorry to be dense. I'm not seeing the issue. Could you explain?
> --Beman

Boost list run by bdawes at, gregod at, cpdaniel at, john at