Boost logo

Boost :

From: Daryle Walker (darylew_at_[hidden])
Date: 2000-07-29 13:40:27

on 7/28/00 2:08 PM, Beman Dawes at beman_at_[hidden] wrote:

> David Abrahams wrote:
>> None of the names I've seen floating around recently address the important
>> difference between what we're trying to name and the standard assert(),
>> namely that ours happens at compile-time. If you're concerned about what
>> unfamiliar readers will be able to understand, consider this possible
>> reaction. "What's this 'verify()' thing? Oh, wonderful. Another case of
>> 'plain old assert isn't good enough for me, I'll write my own'. Stupid
>> boost."
>> COMPILE_TIME_ASSERT says what it means.
> That is certainly clear.
> The real name would presumably be BOOST_COMPILE_TIME_ASSERT. While that is
> lengthy, it probably isn't used in contexts where length matters.
> As John Maddock is going to pull it together, he needs to make a decision
> on the name so we can move on.

Isn't this for a template function/class? So, I don't think it should be in
all capital letters, since it'll look too much like an ugly macro. An
equivalent name could be "compile_time_assert" or "static_assert" (this is
already in the "boost" namespace, so a "boost_" isn't needed).


Boost list run by bdawes at, gregod at, cpdaniel at, john at