From: David Abrahams (abrahams_at_[hidden])
Date: 2000-07-29 14:24:29
----- Original Message -----
From: "Daryle Walker" <darylew_at_[hidden]>
> Isn't this for a template function/class? So, I don't think it should be
> all capital letters, since it'll look too much like an ugly macro. An
> equivalent name could be "compile_time_assert" or "static_assert" (this is
> already in the "boost" namespace, so a "boost_" isn't needed).
Unfortunately, I think we were forced to give up on the ideal of avoiding a
macro for this purpose quite some time ago.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk