Boost logo

Boost :

From: Lois Goldthwaite (loisg_at_[hidden])
Date: 2000-08-17 06:59:33

John Maddock wrote:

> >* Having a class named "reg_match" and a function named "regex_match"
> >caused some confusion. Consider renaming reg_match to
> regex_match_results,
> >match_results, or similar.
> Point taken, I would like to preserve some kind of backwards compatibility
> though for existing users - I guess deriving reg_match from match_results
> or whatever would do it (but not documenting reg_match), I'd like to keep
> the name not too long though - what do people prefer for the name of this,
> ideas?

How about a typedef? "typedef oldname newname;" to preserve binary
compatibility, the other way round if you want to preserve the legacy name but
not encourage it.


Boost list run by bdawes at, gregod at, cpdaniel at, john at