From: David Abrahams (abrahams_at_[hidden])
Date: 2000-09-12 07:24:46
From: "Daryle Walker" <darylew_at_[hidden]>
> on 9/9/00 4:49 PM, David Abrahams at abrahams_at_[hidden] wrote:
> > Overall, it looks good. These incremental improvements should help to
> > complete the picture.
> > Problems:
> > IMO, the names you've chosen for null_default_quantifiable,
> > zero_default_quantifiable, and idempotent are too obscure.
> Do you have better names?
Unfortunately, no. I don't mind idempotent too much; that's technically the
correct name and it's reasonably short. As for the others... well as a
matter of fact I consider implicit conversions hazardous enough that maybe
we shouldn't enshrine them in that way. Maybe whether or not you can find a
good name for something is a measure of the quality of the idea (?)
I'm thinking that unless I hear strong arguments in favor of the
_default_quantifiable templates, we should leave them out.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk