Boost logo

Boost :

From: Beman Dawes (beman_at_[hidden])
Date: 2000-09-19 09:56:49


At 06:48 AM 9/19/2000 -0400, John Maddock wrote:

> ...
>
>This leads on to another design question:
>
>Currently I have:
>
>template <class iterator, class Allocator, class charT, class traits,
class
>Allocator2>
>bool regex_match(iterator first,
> iterator last,
> match_results<iterator, Allocator>& m,
> const reg_expression<charT, traits, Allocator2>& e,
> unsigned flags = match_default);
>
>But with a simplified match_results this can be changed to:
>
>template <class iterator, class Allocator, class charT, class traits,
class
>Allocator2>
>match_results<iterator> regex_match(iterator first,
> iterator last,
> const reg_expression<charT, traits, Allocator2>& e,
> unsigned flags = match_default);
>
>Which IMO makes for more readable code/easier usage. Again this kind of
>change can only be made now while the interface is changing anyway (and I
>should have brought it up before - apologies).

Well, you need to make the decision. This (hopefully) isn't a
design-by-committee exercise. While interface simplification is always
desirable, I don't have enough context to know what the cost is.

--Beman


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk