Boost logo

Boost :

From: Smith, Eric V. (ericsmith_at_[hidden])
Date: 2000-11-15 06:37:55

> > i/ Is the name 'queue' approriate, as the whole idea is to
> allow iteration
> > of the whole interval, whereas a queue traditionally has a
> front and a back,
> > but no knowledge of what lies between.
> I think the name "queue" is too much overloaded.
> What about "wrapping_buffer"?

I've always referred to this data structure as a circular_queue.


Boost list run by bdawes at, gregod at, cpdaniel at, john at