From: Alisdair Meredith (AlisdairM_at_[hidden])
Date: 2000-11-16 02:50:01
--- In boost_at_[hidden], "Smith, Eric V." <ericsmith_at_w...> wrote:
>> I think the name "queue" is too much overloaded.
>> What about "wrapping_buffer"?
> I've always referred to this data structure as a circular_queue.
I think I'll go with the name provided by James
Curran, 'circular_buffer'. I'll look to get a simplistic first
draught uploaded this weekend, based on std::vector. I can look into
turning out a more generalised adapter class after that.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk