Boost logo

Boost :

From: Jens Maurer (Jens.Maurer_at_[hidden])
Date: 2000-11-19 12:57:26

David Abrahams wrote:
> I ask because I think the most sensible name for the nested namespace is
> simply "python".

> namespace python = boost::python;
> python::tuple t(x, y, z);

Looks good to me.

In this case, I favor a nested namespace, because we may have
a (generic C++, not python related) boost::tuple sometime later.

Jens Maurer

Boost list run by bdawes at, gregod at, cpdaniel at, john at