Boost logo

Boost :

From: Kevlin Henney (kevlin_at_[hidden])
Date: 2000-11-22 17:21:50

In message <8vhc1i+g1b7_at_[hidden]>, William Kempf <sirwillard_at_my-> writes
>This is swaying my opinion.


>However, I still don't like the name "function_ptr" here ;). It's
>not a pointer (I wouldn't even consider it a smart pointer) and it's
>not a function. Just my own .02 on something no one else probably
>cares about :).

I definitely consider it a smart pointer, and will heavily defend its
right to be seen as such! It's certainly a proxy, and supports idiomatic
syntax associated with built-in functions, so in my books that makes it
a smart pointer! FWIW, I dislike the callback name as it is too generic
(not in the template sense) and vague (not as in abstract) :->

OK, so now that we've established the two sides of the fence, I guess we
can sit on either side ;-)


  Kevlin Henney phone: +44 117 942 2990
  Curbralan Limited mobile: +44 7801 073 508
  mailto:kevlin_at_[hidden] fax: +44 870 052 2289

Boost list run by bdawes at, gregod at, cpdaniel at, john at