Boost logo

Boost :

From: William Kempf (sirwillard_at_[hidden])
Date: 2000-11-23 09:21:20

--- In boost_at_[hidden], Kevlin Henney <kevlin_at_c...> wrote:
> In message <8vhc1i+g1b7_at_e...>, William Kempf <sirwillard_at_my-
>> writes
> >However, I still don't like the name "function_ptr" here ;). It's
> >not a pointer (I wouldn't even consider it a smart pointer) and
> >not a function. Just my own .02 on something no one else probably
> >cares about :).
> I definitely consider it a smart pointer, and will heavily defend
> right to be seen as such! It's certainly a proxy, and supports
> syntax associated with built-in functions, so in my books that
makes it
> a smart pointer! FWIW, I dislike the callback name as it is too
> (not in the template sense) and vague (not as in abstract) :->
> OK, so now that we've established the two sides of the fence, I
guess we
> can sit on either side ;-)

*laughs* How about choosing neither side? I can see the argument
for it being a smart pointer (even though I think this stretches
things a tad), but baby, it ain't no function ;). That's why the
term "functor" was created. So making an argument that it's a smart
pointer and blasting away at calling it a callback just doesn't sway
me from disliking "function_ptr" as the name here ;).

On the other side, I never really cared for "callback" either. Not
for the reasons you gave, but just because it implies a single useage
that's not forced by the design (i.e. a callback is a general functor
which need not be delayed in it's call). I only chose it because it
was a term well known to everyone that would describe the main reason
why we need such a beast instead of relying solely on generalized

So, in the end, I'd hope we pick some as yet not suggested name. :)

Bill Kempf

Boost list run by bdawes at, gregod at, cpdaniel at, john at