Boost logo

Boost :

From: Beman Dawes (beman_at_[hidden])
Date: 2000-11-24 14:17:48

At 10:42 AM 11/24/2000 -0700, John (EBo) David wrote:

>How about ptr = (Type*) 0; hence convert it explicitly like the
>definituon of NULL as being (void*)0L

AFAIK, the preferred form is static_cast<Type*>(0) when just plain 0 would
result in the wrong overload being selected. See "Effective C++", Scott
Meyers, item 25. But I'm not as much an expert on style as Kevlin.

>> >Well the current names are just as clear as what you're proposing and
>> >they happen to be shorter...
>> "Methods" is only clear to a portion of the C++ community, and on top
>> that sounds pretty dated to my ear.
>> Both of those issues are yesterday's battles. Those who happened to be

>> the losing side just need to move on, rather than fighting the same old
>> fights over and over again.
>Ok... what is the generally accepted terminology these days for the code
>segment of an object? For the data segment?

   member function? member data?

>Hmmm... is this a form of bringing PC to the PC ;-) Just checking...

Yes, it is:-) Challenging political correctness every now and then is a
good idea, too, but probably not in the middle of a discussion of


Boost list run by bdawes at, gregod at, cpdaniel at, john at