Boost logo

Boost :

From: Douglas Gregor (gregod_at_[hidden])
Date: 2000-12-02 11:41:18

On Sat, 2 Dec 2000 14:02:03 +0000
Kevlin Henney <kevlin_at_[hidden]> wrote:

> In message <5Wln5EASGMK6EwHY_at_[hidden]>, Kevlin Henney
> <kevlin_at_[hidden]> writes
> >In message <20001201193344.3e206c74.gregod_at_[hidden]>, Douglas Gregor
> ><gregod_at_[hidden]> writes
> >>My preference would be function_ptr if the callbacks have
> >>reference semantics, or function_obj if they have cloning semantics ("functor"
> >>would be my first choice for cloning semantics because it is concise, but it
> >>appears that it is no longer a usable term).
> >
> >How about function_adapter?
> A possible naming convention has been staring me in the face for ages,
> and I'm disappointed I didn't see it before: any_function. This follows
> any and other any_* classes that I have to resolve the template/virtual
> issue, eg any_iterator.
> This seems to accurately describe its role, reads well in an arg list,
> sidesteps the issue of callbacks/events/etc, and has clearer value-based
> semantics.

I like the idea, but I still think the name chosen must show that it is generalized for function objects, not functions, e.g., any_functor/any_function_obj.

        Doug Gregor

Boost list run by bdawes at, gregod at, cpdaniel at, john at