Boost logo

Boost :

From: Kevlin Henney (kevlin_at_[hidden])
Date: 2000-12-02 13:37:34

In message <20001202114118.0136c0f0.gregod_at_[hidden]>, Douglas Gregor
<gregod_at_[hidden]> writes
>> A possible naming convention has been staring me in the face for ages,
>> and I'm disappointed I didn't see it before: any_function. This follows
>> any and other any_* classes that I have to resolve the template/virtual
>> issue, eg any_iterator.
>> This seems to accurately describe its role, reads well in an arg list,
>> sidesteps the issue of callbacks/events/etc, and has clearer value-based
>> semantics.
>I like the idea, but I still think the name chosen must show that it is
>generalized for function objects, not functions, e.g.,

In which case the name any_function is entirely appropriate: it is
generalised for functions and function objects.


  Kevlin Henney phone: +44 117 942 2990
  Curbralan Limited mobile: +44 7801 073 508
  mailto:kevlin_at_[hidden] fax: +44 870 052 2289

Boost list run by bdawes at, gregod at, cpdaniel at, john at