Date: 2000-12-04 12:51:35
> Ok, but what you have is not clear at all. So how about a couple of
> member functions that indicate the nature of the statement.
> I think you missed understood my complaint. It's not the what PODptr is
> that's the complaint, its that you are again using the magic "0" to have a
> special meaning. And its meaning is known by PODptr and sized_pool, when
> could be known only to POPptr. (Containment and Isolation of
> magic numbers.)
OK. I'll add a member function "valid()" to PODptr. In each case, that's
what's really being tested.
> Thanks for the standard reference on < >= etc.
I'll add something similar to the code comment, too.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk