Boost logo

Boost :

From: Beman Dawes (beman_at_[hidden])
Date: 2000-12-18 14:07:52

Aleksey Gurtovoy wrote:

>1) it might sound as nit-picking, but there is a difference
between 'class
>templates' and 'template classes' terms, and IMO the following (first)
>sentence of the documentation should really use the former term ('class
>templates'): "The header <boost/operators.hpp> supplies several sets of
>template classes (in namespace boost)." BTW, some other boost libraries'
>docs (e.g. one of type_traits), also use the 'template classes' phrase in
>(IMO) wrong contexts...

Don't feel alone on this one - the standard made the same mistake, and so
there is a defect report changing dozens of "template class" -> "class
template" and "template function" -> "function template".

>One last meta comment: I am also sharing Dave's concerns about library's
>grow (given that just recently I citied the library as an example of
>appropriate layering/splitting into parts :). I think that splitting it
>at least three parts (both code and documentation) - basic arithmetic
>operators, iterator adapters and grouped operators, should be done before
>the release. If nobody else, I'll volunteer :).

If you do make this change, please try to figure out a way to resolve
potential confusion between these "iterator adapters" and the "iterator
adaptors" now being formally reviewed. Seems like they might be combined,
but I haven't studied that issue closely.

Damn! I just check the boost HTML pages and the C++ Standard. The Standard
spells it "adaptor" but we spell it "adapter" in a bunch of places. Either
is correct according to my dictionary. I think we should standardize on
"adaptor" to follow the C++ Standard. (The only actual header code where
we spell it with an 'e' is random.hpp: generator_iterator_mixin_adapter. )


Boost list run by bdawes at, gregod at, cpdaniel at, john at