Boost logo

Boost :

From: Daryle Walker (darylew_at_[hidden])
Date: 2000-12-23 19:35:53

on 12/19/00 6:25 AM, David Abrahams at abrahams_at_[hidden] wrote:

> ----- Original Message -----
> From: "Aleksey Gurtovoy" <alexy_at_[hidden]>

[SNIP "class template" v. "template class"]

>> 2) "These templates define many global operators in terms of a minimal
>> number of fundamental operators." (the second sentence) The word 'global'
>> here makes me nervous ;). May be this one is better "These templates define
>> operators in namespace scope in terms of a minimal number of class'
>> fundamental operators."

> That should be "at namespace scope", but yes, I agree. Also, dropping "many"
> as you have is appropriate.


[SNIP template classifications and built-in types]

>> 5) a mistype error - "Composite operator templates >>simply<< list what
>> other templates..."

> Yeah, that should be rephrased anyway: "For composite operator templates,
> only their components are listed. The requirements of composite operator
> templates can be inferred from the requirements of the listed components"

Cleaned that up some more.

[SNIP repeated sentence comment]

>> 7) an important issue - template names; currently they are inconsistent in
>> sense that some of them do follow the standard's terminology and operators'
>> classification, and some of them don't or/and even use the standard naming
>> of operators categories to describe something different; for example,
>> 'additive' and 'mutliplicative' match the standard terminology one-to-one,
>> and 'totaly_ordered' IMO doesn't even come close.

> Do you mean that the name doesn't reflect the standard mathematical meaning
> of "total ordering"?

>> The list of the names I'm
>> concerned about with some comments:
>> * 'totaly_ordered' - isn't plain 'comparable' a better choice?

> No, I don't think so. IMO, the name should be /more/ specialized that
> "less_than_comparable", not less.

I compromised on "totally_comparable".

[SNIP comments on "bitwise_combinable]

>> * 'bidirectionally_shiftable' - again, just plain 'shiftable' (5.8)
>> should be good enough and more standard.

> I'm not sure. I think the same argument as the one against "comparable"
> applies here.

But I liked the new suggestion anyway.

>> * 'logically_invertable' - operator ! is actually called 'logical
>> negation operator' (5.3.1 para 8), so it'll be more correct to call the
>> corresponding operator class template 'logically_negateable' or just plain
>> 'negateable'.

> Yes, that's a much better name, though please drop the first 'e':
> "negatable".


[SNIP comments on "unit_changeable," "idempotent" (to be saved for the
response to this mail), and "LessThanComparable"]

>> 8) HTML formatting issues:
>> * quote of Matt Austern in the 'Note for Users of Older Versions' is not
>> emphased in any way ("", or whatever) as such (at least not on IE5.5)

> I've mentioned this to Daryle in the past. We do need to restore the &quot;
> characters.

"Un"-fixed this to use "&quot;" stuff.

>> * a paragraph symbol (which is a part of the reference to wording of the
>> standard in the same note) is cute :), but the standard format of a
>> reference to the standard ;) is "Section 10.5 paragraph 5" and I think we
>> better stick to it.

> That's probably best.


[SNIP stuff on splitting files]

Daryle Walker
Mac, Internet, and Video Game Junkie
darylew AT mac DOT com

Boost list run by bdawes at, gregod at, cpdaniel at, john at