Boost logo

Boost :

From: Jeremy Siek (jsiek_at_[hidden])
Date: 2000-12-29 17:42:01

On Fri, 29 Dec 2000, David Abrahams wrote:
abraha> I was claiming that it had something in common with transform_iterator,
abraha> which looks like a small generalization of generator_iterator to me.

Ahh. Well, there are enough differences so that both are needed. We should
do some cross referencing or something. The generator_iterator is really
general purpose, and it is currently hidden in the random library. I'd
like to see it moved... perhaps this is a motivation to have a header for
all general-purpose iterator stuff, which would include the adaptors and
the generator_iterator.

abraha> I am worried about the idea of using iterator_generator as a name (though I
abraha> think this is the best choice) while we still also have a
abraha> boost::generator_iterator. Maybe we could dispose of generator_iterator in
abraha> favor of transform iterator, but maybe I shouldn't worry: generator_iterator
abraha> is also a good name ;-)

My $0.02 is to go with iterator_generator and keep generator_iterator. I
think the confusion won't be to bad.


 Jeremy Siek www:
 Ph.D. Candidate email: jsiek_at_[hidden]
 Univ. of Notre Dame work phone: (219) 631-3906

Boost list run by bdawes at, gregod at, cpdaniel at, john at