From: David Abrahams (abrahams_at_[hidden])
Date: 2000-12-29 19:26:50
----- Original Message -----
From: "Jeremy Siek" <jsiek_at_[hidden]>
> On Fri, 29 Dec 2000, David Abrahams wrote:
> abraha> I was claiming that it had something in common with
> abraha> which looks like a small generalization of generator_iterator to
> Ahh. Well, there are enough differences so that both are needed. We should
> do some cross referencing or something. The generator_iterator is really
> general purpose, and it is currently hidden in the random library. I'd
> like to see it moved... perhaps this is a motivation to have a header for
> all general-purpose iterator stuff, which would include the adaptors and
> the generator_iterator.
I think you are probably right. Also, given recent discussions on splitting
up operators.hpp, maybe we should have a boost iterators library where all
of this stuff can cohabitate. It doesn't seem logical to me that people
wanting to implement iterators should have to look through operators,
iterator_adaptors, random, and perhaps boost/iterator.hpp and
boost/detail/iterator.hpp to do so.
While we're in the general subject area, what is your opinion of Daryle's
addition of the iterator archetypes to operators.hpp? It's hard for me to
imagine a use for these separate from the iterator helpers, but before
rejecting the idea I thought I should ask for feedback about it.
> abraha> I am worried about the idea of using iterator_generator as a name
> abraha> think this is the best choice) while we still also have a
> abraha> boost::generator_iterator. Maybe we could dispose of
> abraha> favor of transform iterator, but maybe I shouldn't worry:
> abraha> is also a good name ;-)
> My $0.02 is to go with iterator_generator and keep generator_iterator. I
> think the confusion won't be to bad.
OK by me.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk