Boost logo

Boost :

From: Moore, Paul (paul.moore_at_[hidden])
Date: 2001-03-06 04:29:33

From: Jeremy Siek [mailto:jsiek_at_[hidden]]
> Are you suggesting the following?
> template <class Base,
> class Policies,
> class ValueOrNamedParameters = boost::detail::default,
> class ReferenceOrNamedParameters = boost::detail::default,
> ...>
> class iterator_adaptor;
> and could then be used like the old way:
> iterator_adaptor<int*, default_iterator_policies, int, int&, ...>
> and could also be used like this:
> iterator_adaptor<int, default_iterator_policies,
> iterator_traits_builder
> ::reference<int>
> ::iterator_category<std::input_iterator_tag>

Call me a heretic, if you must, but I wouldn't even contemplate the "new
way" you show above in preference to the "old way". I don't find the "new
way" any more readable. (OK, I need to read the docs to be sure of the order
of parameters with the "old way", but that's nothing new...)

Don't lose the "old way" for the sake of the "new one".

Luddites of the world, unite! :-)

Boost list run by bdawes at, gregod at, cpdaniel at, john at