Boost logo

Boost :

From: David Abrahams (abrahams_at_[hidden])
Date: 2001-03-06 08:02:53


----- Original Message -----
From: "Moore, Paul" <paul.moore_at_[hidden]>

> Call me a heretic, if you must, but I wouldn't even contemplate the "new
> way" you show above in preference to the "old way". I don't find the "new
> way" any more readable. (OK, I need to read the docs to be sure of the
order
> of parameters with the "old way", but that's nothing new...)

At first glance, I tend to fall in the same camp, which is why I'm pushing
for this.

but how about this "new usage", which I think is achievable:

iterator_adaptor<int*, default_iterator_policies,
  named_traits::value_type<int>::category<std::input_iterator_tag> >

but also (equivalently) this:

iterator_adaptor<int, default_iterator_policies,
  int,
  named_traits::iterator_category<std::input_iterator_tag> >

Better?


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk