Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2001-03-16 20:02:21

At 07:48 PM 3/16/2001, David Abrahams wrote:
>----- Original Message -----
>From: "Beman Dawes" <bdawes_at_[hidden]>
>> >> 9) I think the code would be clearer if member data names were
>> >decorated
>> >> somehow, eg fCount, mCount, _count, etc. :-)
>> >
>> >Stylistic suggestion, typically not entertained by Boost
>> >submissions. However, I'm interested in this topic and wouldn't mind
>> >hearing what others have to say on this, even if it's in private e-
>> >mail.
>> Yes, it is stylistic so anything reasonable is acceptable. I've
>> become used to the _count style, and feel most programmers will
>> it right away when they see it. It fits well with the other naming
>> conventions we use. But each to his own...
>...and keeping in mind that names beginning with underscores are reserved

>to the implementation in the global namespace (

Yes. My comment applied only to member names, which was the context of the
original question.


Boost list run by bdawes at, gregod at, cpdaniel at, john at