Boost logo

Boost :

From: Dale Peakall (dale.peakall_at_[hidden])
Date: 2001-04-12 05:20:17

> I was not able to reproduce this problem using VC6 SP5. I'm
> assuming the exact testcase is:
> #include <iostream>
> #include <boost/tuple.hpp>
> int main() {
> boost::tuple<int, int, int> t = boost::tuple<int,
> int, int>(3, 9, 27);
> std::cout << "1: " << boost::get<1>(t) << std::endl;;
> // output's 27!
> // likewise for get<2> and get<3> all output 27
> return 0;
> }

Are you noticed my cunning typo then. Sorry but my development
machine isn't connected to the internet so everything has to be
retyped. It does encourage fairly small example programs.

> Any other information you could give us would be helpful.

I've tried this on two machines now, both return identical results.

One was configured with VC6 SP5, STLPort-4 (although using native
streams so I assume makes no difference), the other with VC6 SP4
and the base Dinkumware STL.

Boost 1.21.1 was used in both cases. The current version of tuple.hpp
from the vault was used.

Project settings: default console project settings, debug and release
builds. Have also tried Debug and Release builds with pre-compiled
headers disabled.

Can't think of any other information that might be helpful.

        - Dale.

Boost list run by bdawes at, gregod at, cpdaniel at, john at