Boost logo

Boost :

From: Hubert HOLIN (Hubert.Holin_at_[hidden])
Date: 2001-05-25 17:28:23

Paris (U.E.), le 26/05/2001

--- In boost_at_y..., Beman Dawes <bdawes_at_a...> wrote:
> At 01:53 PM 5/25/2001, Daryle Walker wrote:
> >I don't think "special_functions" is a good name. Relative to other math
> >stuff, atanh, sinc_pi, and sinhc_pi aren't that special. There can be
> >special functions in other areas besides math. So the name is ambiguous
> in
> >two ways. I've read suggestions here before to start dividing the Boost
> >files into sub-domains, before the main header and library subdirectories
> >get too large. Maybe it can start here, with a structure like:
> >
> >BOOST_ROOT/boost/numeric
> > + quaternion.hpp
> > + octonion.hpp
> > + trigonmetric.hpp (sinc_pi, future stuff)
> > + hyperbolic.hpp (atanh, sinhc_pi, future stuff)
> > + rational.hpp (moved from parent directory)
> >
> >BOOST_ROOT/boost/semi_numeric
> > + random.hpp (moved from parent directory)
> > + random/*.hpp (moved from parent directory)
> > + crc.hpp (moved from parent directory)
> >
> >With mirrored changes in the BOOST_ROOT/libs subdirectory.
> While the details are certainly open to discussion, I think Daryle is right
> about introducing sub-directories for numerics stuff. After working with
> current libraries already in sub-directories (graph/test/random, etc.), I
> find the scheme very intuitive and useful. Benefits greatly outweigh the
> costs.
> As to the distinction between "numeric" and "seminumeric", here is what
> Knuth had to say of his volume 2:
> "The algorithms discussed in this book deal directly with numbers; yet I
> believe they are properly called seminumerical, because they lie on the
> borderline between numeric and symbolic calculation."
> In his book, seminumerical includes random numbers and arithmetic
> (including rational arithmetic).
> To save endless taxonomy arguments, we might want to combine numeric and
> seminumeric.
> --Beman

        As far as sub-directories are concerned, I propose (and have
presented as such in the updated version of my submission)
"special_functions" . Despite the fact that any function can rightly be
call "special", those that should be placed within should be in the
spirit of the usual math collections of such (refer A&S...).

        I also believe we need more namespaces (among which "math"), but
this is more radical.

                Hubert Holin

Boost list run by bdawes at, gregod at, cpdaniel at, john at