Boost logo

Boost :

From: Serge Pashkov (psw_at_[hidden])
Date: 2001-05-29 02:48:24


Hello,

In boost/graph/adjacency_list.hpp there is the following piece of
code:
//---------------
...
#else // !defined BOOST_NO_TEMPLATE_PARTIAL_SPECIALIZATION

#if !defined BOOST_NO_SLIST
  struct slistS {
    template <class T>
    struct gen { typedef std::slist<T> type; };
  };
#endif

  struct vecS {
    template <class T>
    struct bind { typedef std::vector<T> type; };
  };

  struct listS {
    template <class T>
    struct bind { typedef std::list<T> type; };
  };
  
...

  template <class Selector, class ValueType>
  struct container_gen {
    typedef typename container_selector<Selector>::type Select;
    typedef typename Select:: template bind<ValueType>::type type;
  };
//--------------------
  
Is the usage of gen<T> structure for slistS correct or
it should be renamed to bind<T> like other container types?

-- 
Best regards,
 Serge                          mailto:psw_at_[hidden]

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk