Boost logo

Boost :

From: Jeremy Siek (jsiek_at_[hidden])
Date: 2001-05-29 13:01:45


Hi Serge,

You are right, that should be "bind" instead of "gen". I'll do the fix
right now.

Cheers,
Jeremy

On Tue, 29 May 2001, Serge Pashkov wrote:
psw>
psw> #if !defined BOOST_NO_SLIST
psw> struct slistS {
psw> template <class T>
psw> struct gen { typedef std::slist<T> type; };
psw> };
psw> #endif
psw>
psw> struct listS {
psw> template <class T>
psw> struct bind { typedef std::list<T> type; };
psw> };
psw>
psw> ...
psw>
psw> Is the usage of gen<T> structure for slistS correct or
psw> it should be renamed to bind<T> like other container types?

----------------------------------------------------------------------
 Jeremy Siek www: http://www.lsc.nd.edu/~jsiek/
 Ph.D. Candidate email: jsiek_at_[hidden]
 Univ. of Notre Dame work phone: (219) 631-3906
----------------------------------------------------------------------


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk