Boost logo

Boost :

From: Vesa Karvonen (vesa.karvonen_at_[hidden])
Date: 2001-05-29 06:15:45

From: "John Max Skaller" <skaller_at_[hidden]>
> Vesa Karvonen wrote:
>>Currently the PREPROCESSOR library (see Files section/PREPROCESSOR) uses
>>a leading numeric character for "2nd_repeat.h". I will change the header
>>name if someone proposes a better name for the 2nd repetition primitive.
> repeat2.h

"repeat2.h" and the previously suggested "second_repeat.h" are both valid
for the filename. If we decide to change the filename, then I'd go with

I have considered using BOOST_PREPROCESSOR_REPEAT2() for the second
repetition primitive. Unfortunately it sounds like that it would repeat
the expression exactly twice, or start repeating from 2, neither of
which is the purpose of the primitive. (It also collides with
BOOST_PREPROCESSOR_REPEAT, but that can be changed.)

Boost list run by bdawes at, gregod at, cpdaniel at, john at