Boost logo

Boost :

From: williamkempf_at_[hidden]
Date: 2001-06-05 15:02:59

--- In boost_at_y..., jbandela_at_u... wrote:
> --- In boost_at_y..., Douglas Gregor <gregod_at_c...> wrote:
> > I still have a few comments on Tokenizer to throw in:
> >
> > - The include guards contain "JRB015801." Is this intended to
> be updated as
> > the tokenizer version is updated? I'm curious because it's not a
> practice
> > I've seen before.
> In iterator_adapters.hpp there is the #define
> Which I guess is the filename followed by the author's initials and
> the creation date.
> > The name "csv_separator" should probably be changed to something
> more obvious
> > ("csv" is not a common acronym. Perhaps "comma_separator"?)

Actually, csv is a common acrony standing for "comma seperated

> I have had trouble thinking of a good name as well. Since
the "comma"
> does not have to be a comma, comma_separator might be misleading. A
> name that reflects what it really is would be
> escaped_quoted_delimited_field_separator which is too unwieldy.
> ideas as to a better name would be appreciated.

token_value_seperator? This is a little ambiguos, but if you know
what a csv format is the use of value here should be enough to
comprehend the name.
Bill Kempf

Boost list run by bdawes at, gregod at, cpdaniel at, john at