Boost logo

Boost :

From: Douglas Gregor (gregod_at_[hidden])
Date: 2001-06-08 13:49:25

On Friday 08 June 2001 02:25 pm, you wrote:
> on 6/7/01 9:09 PM, Douglas Gregor at gregod_at_[hidden] wrote:
> > The function library currently under review contains a type 'nil_t' with
> > an instance 'nil'. It is a replacement for "0" or "NULL" in any code. The
> > implementation is trivial, but it should probably be placed in its own
> > header because its usefulness extends beyond 'function'. The code is
> > just:
> Like someone else said, we would have to avoid the name "nil" since it's
> used as a macro in Apple system code. I like the name "null" better.
> Also, shouldn't there be comparisons with pointers-to-member too? A
> revised class could be:

Yes, there should. Thanks.


Boost list run by bdawes at, gregod at, cpdaniel at, john at