Boost logo

Boost :

From: jk_at_[hidden]
Date: 2001-06-08 23:42:06


8 Jun 2001 23:14:18 +0400 Douglas Gregor ÎÁÐÉÓÁÌ:
>> Like someone else said, we would have to avoid the name "nil" since it's
>> used as a macro in Apple system code. I like the name "null" better.
>> Also, shouldn't there be comparisons with pointers-to-member too? A
>> revised class could be:
>[snip]
>
>Yes, there should. Thanks.

Why not to leave type name as it is, nil_t? It is less to type :) and it seems
there is no name conflicts. Then everyone could define theirs own literals as
they wish:

namespace {
        const boost::nil_t null;
        const boost::nil_t NoOneWantsToUseThisVeryLongName;
        const boost::nil_t nn; // for lazy people :))
}

and use temporary objects:

int f(boost::nil_t);
f(boost::nil_t());

-- 
jk

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk