Date: 2001-06-14 09:06:02
--- In boost_at_y..., Douglas Gregor <gregod_at_c...> wrote:
> On Thursday 14 June 2001 07:13, you wrote:
> > I wonder whether the "detail" namespace should be replaced with
> > "function_detail" or "function::detail" whichever you prefer - I
> > about namespace clashes if everyone uses "detail". Having said
that if you
> > don't think that it's a problem then leave it for now.
> Function has a lot of helper classes, so it probably should have
> detail namespace.
This has been brought up before, and I thought the suggested
alternative was boost::detail::library (in this case
> > Like almost everyone else I'm not keen on boost::nil, personally
> > just leave it out, but if you really want it, then renaming to
> > else seems to be in order (to avoid the mac problem).
> I really like 'nil' (because I dislike OO-style interfaces for
> components), but I'll go with the general consensus.
Just a personal comment here. I like the idea of "nil", but I'm
afraid that there are some hidden dangers that have not been
discovered yet. I'd prefer to leave "nil" out in a first release,
insuring a safe interface for now, then after existing practice with
the concept has been obtained consider introducing "nil" back into
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk