Boost logo

Boost :

From: Greg Colvin (gcolvin_at_[hidden])
Date: 2001-06-27 16:21:58

From: <williamkempf_at_[hidden]>
> ...
> 1. I still worry about the lack of self().

So why not have it?

But then, why call it self() instead of current()?

> 2. We need to figure out which is better, to detach() or join() in
> the destructor. Conceptually detach() seems like the best
> alternative, but this may complicate some user code where join()
> needs to be called. Otherwise it seems to be a coin flip and we just
> need to pick one and stick with it.

I prefer detach, so that an explicit detach() function is
not needed. It's easy enough to join() when appropriate.
But then I've yet to write an application that needed to

Boost list run by bdawes at, gregod at, cpdaniel at, john at