Boost logo

Boost :

From: williamkempf_at_[hidden]
Date: 2001-06-27 17:19:43

--- In boost_at_y..., "Greg Colvin" <gcolvin_at_u...> wrote:
> From: <williamkempf_at_h...>
> > ...
> >
> > 1. I still worry about the lack of self().
> So why not have it?
> But then, why call it self() instead of current()?

A rose by any other name would smell as sweet, a turd as foul. In
other words, I don't care about the name, I care bout the operation.
We can argue names later.

> > 2. We need to figure out which is better, to detach() or join()
> > the destructor. Conceptually detach() seems like the best
> > alternative, but this may complicate some user code where join()
> > needs to be called. Otherwise it seems to be a coin flip and we
> > need to pick one and stick with it.
> I prefer detach, so that an explicit detach() function is
> not needed. It's easy enough to join() when appropriate.
> But then I've yet to write an application that needed to
> join.

Our experiences differ. I very rarely have need for a detached

Bill Kempf

Boost list run by bdawes at, gregod at, cpdaniel at, john at