Boost logo

Boost :

From: Jeremy Siek (jsiek_at_[hidden])
Date: 2001-07-18 13:15:18

On Wed, 18 Jul 2001 williamkempf_at_[hidden] wrote:
> 1) I don't find it to be so awful.
> 2) I'd prefer to choose a different name for spinlock.

But "spinlock" is the name everyone uses.

> 3) I doubt we add a spinlock to Boost.Threads any way.

Really? Spinlocks may not be good general purpose mutexes, but there are
lots of situations where they are the right choice. I think that spinlocks
should definitely be in Boost.Threads. If we don't put them in, then
people will just create there own... I think it's better to have a
standard version.


 Jeremy Siek www:
 Ph.D. Candidate, IU B'ton email: jsiek_at_[hidden]
 Summer Manager, AT&T Research phone: (973) 360-8185

Boost list run by bdawes at, gregod at, cpdaniel at, john at