Date: 2001-07-18 13:01:59
--- In boost_at_y..., "Alexander Terekhov" <terekhov_at_d...> wrote:
> > The name "locker" is just awful. Guard is tolerable,
> > but doesn't convey the action well.
> how about LockKeeper; similar to DirKeeper from
Only slightly better. Generally, I find any name that has to be
turned into a noun by adding "er" to be a bad choice. Often the
result is either not a proper English word, or it means something
totally different than what was meant, or it's just plain ambiguous.
In this case it's ambiguous. In order to "keep" a lock there must be
a lock object, no? A better name than any suggested so far (other
than lock, IMHO) would be auto_lock. I'm just not convinced that we
should change the name at all.
> > I really don't understand why you find the
> > name "lock" to be bad.
> boost::spinlock lock_;
> boost::spinlock::lock lock( lock_ );
> is just awful, IMHO.
1) I don't find it to be so awful.
2) I'd prefer to choose a different name for spinlock.
3) I doubt we add a spinlock to Boost.Threads any way.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk