Boost logo

Boost :

From: Howard Hinnant (hinnant_at_[hidden])
Date: 2001-08-16 20:48:13

On Thursday, August 16, 2001, at 08:45 PM, Greg Colvin wrote:

> Since others might still object, and since there are related defect
> reports being resolved, and since shared_ptr may be presented to
> the committee soon, I think it is time to gather up the various
> suggestions for improvements and plan on a formal review of the
> possible changes.

One of the possibilities I would like to see explored is merging
shared_ptr and shared_array under the same name using a specialization
on array types. That is instead of:

shared_ptr<int> p1(new int);
shared_array<int> p2(new int[3]);

rather this:

shared_ptr<int> p1(new int);
shared_ptr<int[]> p2(new int[3]);

This is purely a naming issue. I don't see any issues regarding generic
programming or the like.


Boost list run by bdawes at, gregod at, cpdaniel at, john at