Boost logo

Boost :

From: Gustavo Guerra (gustavobt_at_[hidden])
Date: 2001-08-17 16:33:50

> Secondly, I don't think the name bind is appropriate. This
> suggests too close a link to the standard binders, and thus
> that Peter's bind is a function object adapter. In fact,
> this new submission is the beginnings of an expression
> template library, and the name should reflect that. Indeed
> since "bind" allows us to create function objects in which
> nothing is actually bound, I perhaps "call" or "apply" would
> be more appropriate:
> boost::call( f, _1, _2 )( x, y );
> boost::apply( f, _1, _2 )( x, y );

What do you think about

     boost::curry( f, _1, _2 )( x, y );

Gustavo Guerra

Boost list run by bdawes at, gregod at, cpdaniel at, john at