Boost logo

Boost :

From: Daryle Walker (darylew_at_[hidden])
Date: 2001-08-30 17:52:27

on 8/30/01 3:13 AM, David Abrahams at david.abrahams_at_[hidden] wrote:

> ----- Original Message -----
> From: <helmut.zeisel_at_[hidden]>
>> On Monday, I sent an updated version of operators.hpp and operators.htm
>> (based on the version in boost_1_24_0) per mail to you. Since I did not
>> receive any reaction, I assume it is lost.
> Not lost, but I'm extremely busy at the moment. What I saw looked good.
>> Now I uploaded the same version:
> That's probably best, so now others concerned (I'm thinking of Daryle and
> Aleksey) can have a look.

It looks OK. But should the prefix be "_left"? Would something like
"_reversed" be better?

Some minor points (some with locations from Helmut's HTML file):

1. In the output iterator section of the documentation, there is a ">" not
escaped to a "&gt;" in the sample code. (Line 1190) I know it's an
leftover error, and not by Helmut.
2. Both of the new <h4> headers have closing </h3> tags instead of </h4>.
Those screw up my HTML checker, besides error [1]. (Lines 158 and 185)
3. The table entries showing the requirements for the new "_left" templates
should use a semicolon ("T temp(u); temp -= t") between the statements
instead of a period ("T temp(u). temp -= t").
4. As David said, some of the new text needs to be clearer.
5. Will test cases be made for the new (basic) templates?

Daryle Walker
Mac, Internet, and Video Game Junkie
darylew AT mac DOT com

Boost list run by bdawes at, gregod at, cpdaniel at, john at