Date: 2001-08-31 02:01:43
--- In boost_at_y..., Daryle Walker <darylew_at_m...> wrote:
> It looks OK. But should the prefix be "_left"? Would something
> "_reversed" be better?
I do not think that the postfix "_left" is perfect,
but I also do not think that "_reversed" would be better.
I actually had "_reverse" in a previous version,
but I switched to "left" because
looking at "U-T" and "T-U" I cannot tell which is
the "normal" and which is the "reverse" version.
I can tell, however, whether "U" is on the left hand
or right hand side.
Clearly I could also look at "T" and say the "T" apears
on the right hand side in my version,
but it will look a bit arrogant if I call my version the
right/correct one :-).
So I can say that I added the left/remaining version
to complete the interface ...
But anyway, since the name needs a long explanation,
it might not be a good name. I, however, do not know
a better one.
> Some minor points (some with locations from Helmut's HTML file):
I corrected points 1-4.
Updated version is on
> 4. As David said, some of the new text needs to be clearer.
Do you refer to the first version or to my updated version 2,
where I incorporated suggestions from David.
In the latter case, can you be a bit more specific
what still should be improved?
Maybe some things look very obvious to me from inside
but are still unclear to someone seeing the things from outside.
> 5. Will test cases be made for the new (basic) templates?
I tested it with my integer class.
If there is need, I can also add tests directly to
I am sorry to say, however, that I cannot do this before
end of September since I will be on leave
for the next three weeks.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk