Boost logo

Boost :

From: Scott McCaskill (scott_at_[hidden])
Date: 2001-09-24 17:25:29

> As for changing the name... one name change request that's been made
> several times that I've ignored I'd like to address one last time.
> The notify_one() and notify_all() methods on condition are more
> traditionally known as signal() and broadcast() respectively. I was
> persuaded to change them at one point, but I'm feeling like this was
> a mistake. I'm leaning towards changing them but I'll need to do so
> in the next day or two, so one final chance to argue this one.

notify_one and notify_all are more descriptive of what these methods do and
their relationship to each other. Those who are already familiar with
signal and broadcast will almost certainly already understand the
functionality behind those names and should have little trouble equating new
names with concepts they already understand.

For those with less knowledge of the underlying concepts, descriptive names
will be beneficial, while historical names may not be. broadcast is not
bad, since it implies a potential one-to-many style of communication.
However, I can't see how one could interpret signal to be a counterpart to
broadcast (historical uses aside)--the definition of signal does not imply a
one-to-one relationship between the signaller and the signalled.

Scott McCaskill

Boost list run by bdawes at, gregod at, cpdaniel at, john at