Date: 2001-09-26 14:23:58
Neither "iteratible" nor "iteratable" are words. Webster's Revised
Unabridged Dictionary says the correct word is "iterable".
--- In boost_at_y..., "David Abrahams" <david.abrahams_at_r...> wrote:
> OK. Daryle, if you will change "iteratible" to "iteratable" I will
> your submission as is. Feel free to email it to me personally.
> make any other changes though, because they would cause another
> iteration ;-)
> ----- Original Message -----
> From: "Aleksey Gurtovoy" <alexy_at_m...>
> To: <boost_at_y...>
> Sent: Wednesday, September 26, 2001 7:12 AM
> Subject: RE: [boost] Re: Separate iterator operators from iterator
> > David Abrahams wrote:
> > > I was hapy with bidirectional_iterator_operators, but
> > > "bidirectional_iteratible" doesn't work at all for me.
> > Apparently, '[...]_iterator_operators' names (that I like too)
> > well into the general naming convention used through the rest of
> > (that is documented in our "Summary of Template Semantics"; in
> > item 2 of that section says: "The name of an operator class
> > indicates the /concept/ that its target class will model").
> > > I'm not sure if "iteratible" is a word, but if it is, I think
> > > it would be spelled "iteratable". In any case, I'd like to
> > > hear from others about the choice of names. Jeremy?
> > > Aleksey?
> > IMO if you think about "[input,output,..]_iteratable" as a name
> > concept, it becomes an acceptable choice. At least I am ok with
> > Google search on "iteratable" finds ~70 distinct pages where the
> > used, mostly in CS texts, and at least one seemed to talk about
> > mathematics :).
> > Aleksey
> > Info: http://www.boost.org Unsubscribe:
> > Your use of Yahoo! Groups is subject to
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk