Boost logo

Boost :

From: Toon Knapen (toon.knapen_at_[hidden])
Date: 2001-10-10 05:31:09

I tried to build the boost.jam on IBM and only encountered the problem
that yyacc was not executable. After a 'chmod +x yyacc', the jam
executable was generated.

However, I still get the same errors when launching 'jam' as with FTJam :

<\begin terminal output>
biot:/home/tk/boost/tools/build/jam_src/bin.aix> ./jam
+: line 1323: yacc stack overflow at string "
$(AR) $(<) -+$(>)
don't know how to make all
...found 1 target...
...can't find 1 target...
<\end terminal output>

On SGI, jam compiled fined (after setting the executable flag on
'yyacc'). Some time ago, you agreed with my proposition to provide
jam-executables to the boost users for the most popular platforms. Do I
already check in the SGI version and where ?

On HP (HP-UX 10.20) I did not succeed in building 'jam0' since 'alloca'
is an undefined symbol. I have searched through all system libraries but
could not find a definition of alloca. The man page directed me to an
old library which neither defined 'alloca'. I found some information on
the web though confirming that 'alloca' is indeed missing on (some / all
?) HP-UX machines together with an open-source implementation of the
(ref :

Boost list run by bdawes at, gregod at, cpdaniel at, john at