From: Paul A. Bristow (boost_at_[hidden])
Date: 2001-10-30 07:52:59
> -----Original Message-----
> From: Rainer Deyke [mailto:root_at_[hidden]]
> Sent: Monday, October 29, 2001 7:52 PM
> To: boost_at_[hidden]
> Subject: Re: [boost] Math constants - naming convention?
> ----- Original Message -----
> From: "Stewart, Robert" <stewart_at_[hidden]>
> To: <boost_at_[hidden]>
> Sent: Monday, October 29, 2001 10:53 AM
> Subject: RE: [boost] Math constants - naming convention?
> > PI_1_2
> > PI_1_4
> > PI_1_3
> > PI_2_3
> > PI_2
> In general, I consider it a mistake to include small integers in an
> whether as digits or spelled out. It places a greater burden on the
> user (because they have to remember that 'PI_1_2' exists but
> 'PI_156785_786971290' doesn't)
I you don't need/want/remember, then you don't have to use the few small
But they are always the right size and are clear and consistent.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk