Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-11-25 15:49:46

----- Original Message -----
From: "Andrei Alexandrescu" <andrewalex_at_[hidden]>
> > Of course they all do the same thing, so we only need one of these - it
> > depends on which way you look at it I guess - personally I prefer
> > "is_public_base", as it's the easiest to understand what it does (I
> > get "superclass" and "subclass" mixed up, and I'm sure I'm not alone!)
> That's exactly the argument that MC++D makes in favor of the name
> SUPERSUBCLASS in favor of anything else. You can't get it wrong.

Huh? SUBSUPERCLASS makes about as much sense to me... which is to say that
it makes no sense to me. I would prefer a name using the word "derived",
whose meaning is hard to mistake.


Boost list run by bdawes at, gregod at, cpdaniel at, john at