Boost logo

Boost :

From: Andrei Alexandrescu (andrewalex_at_[hidden])
Date: 2001-11-25 17:04:44

From: "David Abrahams" <david.abrahams_at_[hidden]>
> From: "Andrei Alexandrescu" <andrewalex_at_[hidden]>
> > That's exactly the argument that MC++D makes in favor of the name
> > SUPERSUBCLASS in favor of anything else. You can't get it wrong.
> Huh? SUBSUPERCLASS makes about as much sense to me... which is to say that
> it makes no sense to me. I would prefer a name using the word "derived",
> whose meaning is hard to mistake.

"Superclass" and "subclass" are two quite accepted names both in OOP theory
and practice.

Anyhow, that's not the point. The idea is that the order of the two classes
appears in the name. In super_subclass you know that the superclass is first
and subclass is second. In sub_superclass you would know that the subclass
appears first and the superclass appears second. A name such as base_derived
would be just as good.

But a name such as "subclass" or "derived" would not make clear which class
is first and which is second.


Boost list run by bdawes at, gregod at, cpdaniel at, john at