Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-11-26 08:10:19

----- Original Message -----
From: "Mark Rodgers" <mark.rodgers_at_[hidden]>

> From: "Andrei Alexandrescu" <andrewalex_at_[hidden]>
> >
> > Duly noted. So I changed the name to is_base_derived.
> Hmm seems like bad grammar to me. Are we not asking
> "are these two classes related by a base-derived
> relationship?" IOW it's a test on *both* classes so
> are_base_derived seems better. I'd really like
> are_base_and_derived.

I had exaclty these thoughts.

> Alternatively, could we (and should we) use named
> template parameters as in the iterator adapters library?
> I.e. tbd< base<B>, derived<D> >::value where tbd is a
> name to be decided, perhaps just "are".

Hmm; we'd be preparing to stuff detection of all class relationships (in the
future) though this one template, but I suppose that with partial
specialization that's no problem; rather nice, actually. The workarounds I
can think of for compilers without partial specialization are somewhat
painful, though.


Boost list run by bdawes at, gregod at, cpdaniel at, john at