Boost logo

Boost :

From: Mark Rodgers (mark.rodgers_at_[hidden])
Date: 2001-11-26 03:06:56

From: "Andrei Alexandrescu" <andrewalex_at_[hidden]>
> Duly noted. So I changed the name to is_base_derived.

Hmm seems like bad grammar to me. Are we not asking
"are these two classes related by a base-derived
relationship?" IOW it's a test on *both* classes so
are_base_derived seems better. I'd really like

Alternatively, could we (and should we) use named
template parameters as in the iterator adapters library?
I.e. tbd< base<B>, derived<D> >::value where tbd is a
name to be decided, perhaps just "are".


Boost list run by bdawes at, gregod at, cpdaniel at, john at