Boost logo

Boost :

From: Howard Hinnant (hinnant_at_[hidden])
Date: 2001-11-27 13:26:12

On Tuesday, November 27, 2001, at 11:52 AM, Andrei Alexandrescu wrote:

> From: "Peter Dimov" <pdimov_at_[hidden]>
>> Finally, I like the int2type<> and type2type<> names. They are
> sufficiently
>> obvious to me. I don't see a need to change them into *_identity.
> You know, after all the tossing around, I would love to return to them,
> too.
> Besides, they are known because of Mc++D and articles.


I'm currently reworking one of the Metrowerks containers. Historically
I've used a nested class in each container:

        template <bool b> struct chooser {};

to do the compile time testing of iterators (to make sure they really
are iterators) and dispatching to the correct methods to implement
23.1.1/9 (the "do the right thing" clause).

But I would just as soon use int2type which is easier to read than
chooser because of Loki's success (and which works just great with bool
arguments). Andrei, with your permission I would like to put
Metrowerks::int2type in our <msl_utility>.


Boost list run by bdawes at, gregod at, cpdaniel at, john at