Boost logo

Boost :

From: Jonathan H Lundquist (jhl_at_[hidden])
Date: 2001-11-27 19:05:10


Personally, I prefer type2type, simply because I already use the name
'identity' for the following:

template<typename T>
struct identity : public unary_function<T, T> {
   const T& operator()(const T& x) const throw()
   {
      return x;
   }
};

> Message: 19
> Date: Mon, 26 Nov 2001 12:30:39 -0800
> From: "Andrei Alexandrescu" <andrewalex_at_[hidden]>
> Subject: Re: Submission: typelist
>
> From: "David Abrahams" <david.abrahams_at_[hidden]>
>> BTW, isn't "identity" a much better name than "type2type"?
>
> Identity sounds great, I'll make that change unless there is a lot of
> opposition.
>
> Andrei


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk