Boost logo

Boost :

From: Andrei Alexandrescu (andrewalex_at_[hidden])
Date: 2001-11-28 18:26:11

From: "David Abrahams" <david.abrahams_at_[hidden]>
> as long as we're tinkering with names, consider "value_t" or
> "value_type":
> template <typename T, T x>
> struct value_t
> {
> static T const value = x;
> };
> template <int x>
> struct int_t : value_t<int, x> {};
> Did somebody already suggest that?

I fear these will engender confusion because they are similar to size_t and
ptrdiff_t, types that don't have a generic programming conotation. So
someone seeing int_t might think "hmmm, this must be some platform specific
integral type..."


Boost list run by bdawes at, gregod at, cpdaniel at, john at